Admin portal not recognizing Sendgrid API Key

Hi all - I’m trying to enable outgoing email from my app. I got a heads up from a user that the reset password email wasn’t working, and I think it’s because I haven’t enabled Sendgrid yet.

I went in and created a new API key using my sendgrid account, and I added the API key on the plug in page as the instructions said, but it’s not recognizing it in the admin portal. See screenshots below:

API key in plugins tab:

Admin portal:

Hello @toby !

Make sure that your sender email is verified in Sendgrid

Hey! Sorry I am replying very late to this. Attempting to set up the sendgrid API once again and it’s giving me a new error. Any ideas?

Hi @toby !

Usually most of the issues with Sendgrid get resolved bye going to your Sendgrid dashboard and verifying the sender email there.

It says that it’s verified?

Does the email that I use for my sendgrid account need to match my verified sender email?

Yes it does need to match :grinning:

Still no luck… I changed my sendgrid account email to team@chezie.co, I made team@chezie.co the single sender… any other ideas?

@toby

Back in the day I also experienced issues with setting up Sendgrid. It is a challenging experience to figure our the problem … when it exists … for sure!

How about creating a new app with the free Canvas template and try settings things up there following each step in the instructions … to the comma.

You may be able to identify the problem this way.

okay will attempt this this weekend. thanks

So i tried this… the issue is that the template I’m using for my current app is a much older version than the current canvas template. meaning that the UI for updating the sender email isn’t the same - see screenshots.


and, even when I try to update the sender email in my old app, I get the error shown in the screenshot above. any other ideas? Is there any way to escalate this?

@toby

So, I gather that Sendgrid worked for the new test app worked while it does not for your current app. Correct?

yes. that’s correct.

Hello @toby !

Please send your app’s editor link and set it temporarily to be editable in public in general/settings:

Choose report a bug here please: