Cannot sign-in (2FA Mobile Setup) No SMS Text Message Received - Australia

Hi,

I have reported this bug but making this post so it cache’s in Google for anyone experiencing the same issue.

Upon logging in as a new user, I am prompted by Canvas to register a Mobile phone number for 2FA when logging into the admin account in the backend. I enter a phone number (+61) XXXXXXXXX and no text message is received with code, so I cannot confirm the 2FA process.

There is no alternatives, it’s simply receive the code, if not, you’re locked out.

I tried with alternative phone number, same result.

This is a huge inconvenience, and 2FA should be optional, and if not at least optional, open the options for 2FA to be TOTP accessible.

Hello @user35 welcome to the community!

Perhaps the 2FA functionality may no not have been set up in the application.

When you preview and it has not been set up you run against that issue. One way to circumvent it is to manually add a date on the user object a date for the field “date last verified”

Or … upon every user signing up like this:

image

The 2FA setup can take place following these instructions: