Signup email verification is not sent (updated)

On signup, the e-mail verification with the code doesn’t get sent (one e-mail went through, then it stopped however I didn’t do any changes).

What I tried:

-Installing and uninstalling Email for Canvas, Rich Postmark emails and Postmark Email. Tried having them installed all together as well as Email for Canvas with one of the Postmark, as well as separately.

-Checked that server key (API key) is added, and account token as well where required.
Tried with and without the dev option.

-Domain is approved and active on Postmark, DKIM and return-path verified. There are enough unused emails to send.

-I renamed the server on Postmark at some point - tried renaming it back to what it was when it worked - didn’t help.

-The toggle for the verification email on the Canvas dashboard is on (Email → Sends a verification code to confirm the user’s email during sign-up).
Double-checked the Data → App Data → All App Settings → Email verification is set to “Yes”.

-The Outgoing email is setup and confirmed in the Canvas account dashboard

-Bubble is on the paid plan that supports API (Personal plan)

-Workflow in Bubble doesn’t have any errors and shows that the email was sent (at least as I understand it does - can share screenshots or link)

-Contacted Postmark support and they confirmed that on their end everything works and told that the problem is with login or Bubble.

-Reached out to AirDev and was recommended setting up Verify Setting up two factor authentication - Canvas Manual. I followed step 2 and set it up however it didn’t help.
But if this was the reason - how did the first email get sent?

What else might be missing? Everything seems to be in place. Please let me know if you have any recommendations on what else to check. Thank you!

Hello @oliveox !

I believe one of my colleagues solved the issue for you through support@airdev.co

If this is not the case please contact support@airdevl.co so that we can assist.

Note for other readers: In a recent support ticket on email verification, our documentation was not clear enough to guide users to ensure that the Postmark API Key was entered incorrectly in the API Connector. The format is ‘Beaerer {{Private key}}’ and in the ticket’s app it was entered as {{Private key}} only.

The documentation is now more clear on this so others can avoid entering the mail provide API key incorrectly. :smiley:

1 Like